Bad request (400) on file uploads
Incident Report for SimpleLocalize
Postmortem

We started preparing the system to gather logs for better auditing on application level. This requires us to read request bodies and responses multiple times. However, due to an incorrect implementation, multipart requests with files were not handled properly in some cases, leading to a 400 Bad Request response, even when the requests were valid.

Posted Jan 09, 2025 - 19:10 CET

Resolved
Between 18:16 CET and 18:30 CET, the system was rejecting correct requests with file uploads. This issue affected the API, Web, and CLI. We apologise for the extra effort it caused.
Posted Jan 09, 2025 - 18:15 CET